1

我有一个安装了 Cisco XE 的 Cisco CSR 路由器。

我想显示我的路由器的 YANG 功能。

我的代码如下:

主文件

from ncclient import manager
import xml.etree.ElementTree as ET

router = {
    "host": "10.0.0.1",
    "port": "830",
    "username": "admin",
    "password": "******",
}

with manager.connect(
    host=router["host"],
    port=router["port"],
    username=router["username"],
    password=router["password"],
    hostkey_verify=False,
    allow_agent=False,
    look_for_keys=False,
) as m:
    ip_schema = m.get_schema("ietf-ip")
    root = ET.fromstring(ip_schema.xml)
    yang_tree = list(root)[0].text
    f = open("ietf-ip.yang", "w")
    f.write(yang_tree)
    f.close()

另外,请在路由器上找到我的节目:

MyRouter#show run
Building configuration...

Current configuration : 1725 bytes
!
! Last configuration change at 10:17:15 UTC March Oct 6 2021
!
version 16.8
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
platform console serial
!
hostname MyRouter
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$tK3F$2WEFfM8JZcyP7YPgzRZbH1
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
!
!
!
!
!
!
!
ip domain name myrouter.com
!
!
!
!
!
!
!
!
!
!
subscriber templating
!
!
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CSR1000V sn 96YNK5Y0HUS
no license smart enable
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
netconf-yang
!
!
username admin privilege 15 secret 5 $1$h/2L$vvzIggHKLFlS1KJlYOqkA1
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet1
ip address 10.0.0.1 255.255.255.0
ip nat outside
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet2
no ip address
shutdown
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet3
no ip address
shutdown
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet4
no ip address
shutdown
negotiation auto
no mop enabled
no mop sysid
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.0.0.3
!
ip ssh version 2
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
line con 0
stopbits 1
line vty 0 4
transport input ssh
!
netconf ssh
wsma agent exec
!
wsma agent config
!
wsma agent filesys
!
wsma agent notify
!
!
end

当我运行代码时,它给出了一个错误 `ncclient.transport.errors.SSHError: Could not open socket to 10.0.0.1:830

知道是什么原因造成的吗?

4

1 回答 1

0

首先,您需要确定您的路由器上是否启用了 netconf。

telnet 10.0.0.1 830你可以通过从你的机器发出一个 SSH 命令来做到这一点。

如果 telnet 连接成功,那么说明你在 python 中缺少 SSH 模块。

您可以通过使用以下命令安装 Paramiko 来解决此问题pip install paramiko

如果 telnet 失败,则只需使用命令在 Cisco 路由器上启用 netconf,然后netconf-yang重试。

于 2021-03-06T19:02:40.740 回答