这不是一个特定于代码的问题,而是一个 Objective-C 命名法问题。在 C 中,你有纯数据的结构。在 Enterprise Java 中,您有“bean”类,它们是具有 getter 和 setter 的纯成员变量,但没有业务逻辑。在 Adobe FLEX 中,您有“值对象”。
在 Objective-C 中,对于一个只有 ivars 和 getter/setter(或者 @property/@synthesize,如果你想花哨的话)并且没有真正的业务逻辑的对象(当然是从 NSObject 继承)是否有合适的名称?
一个更具体的示例可能是一个简单的类,其中包含用于文件名、文件大小、描述和各种其他元数据的 getter 和 setter。然后,您可以将其中的一堆轻松放入容器(NSDictionary、NSArray)中,而无需对 C 结构进行凌乱的 NSValue 包装。它也比将一堆松散类型的子 NSDictionaries 放入父容器对象中更多的结构。