A small thing, but I will be happy to hear what other people think about it.
Which of the 2 code segments below is the best programming practice?
var results = GetResults();
SendResults(results);
OR:
SendResults(GetResults());
I think that the first option is better, but on the other hand option 2 is less code to write (and read). What do you think?
I know it's a very basic question, but still...