假设我有这个课程:
classdef abstractGame
%UNTITLED Summary of this class goes here
% Detailed explanation goes here
properties
end
methods (Abstract, Static)
run(gambledAmount);
end
methods (Static)
function init()
gambledAmount = validNumberInput(abstractGame.getGambleString(), 1, 100, 'helpText', 'round');
end
function str = getGambleString()
str = 'How much do you want to gamble?';
end
end
end
其他类从这个类扩展而来。我希望子类重新定义 getGambleString 方法,并让 init 方法使用最深的类定义的方法(而不是 abstractGame.[...] 我想要类似 calledClass.[...] 的东西)。
我该怎么称呼它?提前致谢。