I am trying to merge a directory in subversion, but I get the following error when I do so:

svn: Working copy '[directory name]' not locked'

I tried deleting the working directory and doing a fresh update, but that did not solve the issue. I also did a cleanup on the directory.

Does anyone know how to fix this?

In this instance, the parent directory has the same name as the sub directory. I don't know if this has anything to do with the error though.


5 回答 5


Check out this blog posting (Obscure "svn mv" problem solved)... I typically just remove the directory and grab fresh sources.

于 2008-09-18T18:45:28.537 回答

我使用 IDEA 遇到了这个错误。我通过在 Windows 资源管理器中进行乌龟 svn 清理来解决这个问题,IDEA 中的等效清理不起作用。

于 2009-03-11T16:24:21.483 回答

Are you by chance using TortoiseSVN and some other client (Such as subversive or the commandline client?). Sometimes Tortoise can unintentionally gum up other clients. I don't remember what exactly causes this to happen.

于 2008-09-18T18:56:26.077 回答



于 2008-09-18T19:27:01.993 回答

Try doing a clean-up and then an update. If that not work, please explain better your issue.

于 2008-09-18T18:55:47.963 回答